Can't seem to get it working

Apr 17, 2010 at 1:13 AM

I followed the instructions and got the following :

 

Configuration Error

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Unrecognized configuration section WebConfigRoleProvider.

Source Error:

Line 20: 	</configSections>
Line 21: 
Line 22:   <WebConfigRoleProvider>
Line 23:     <roles>
Line 24:       <add name="Admin" users="xxx, xxx, xxx, Admin" /> <!--redacted -->


Source File: C:\src\BZTEntry\BZTEntry\web.config    Line: 22


Show Additional Configuration Errors:

Unrecognized configuration section authentication. (C:\src\BZTEntry\BZTEntry\web.config line 109)
Unrecognized configuration section authorization. (C:\src\BZTEntry\BZTEntry\web.config line 123)

 

Apr 17, 2010 at 1:26 AM

AND ...

Configuration Error

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Exception has been thrown by the target of an invocation.

Source Error:

Line 32:       <roleManager enabled="true" defaultProvider="WebConfigRoleProvider">
Line 33:         <providers>
Line 34:           <add name="WebConfigRoleProvider" type="WebConfigRoleProvider.Core.WebConfigRoleProvider"/>
Line 35:         </providers>
Line 36:       </roleManager>

 

Coordinator
Apr 17, 2010 at 2:52 AM

Hi mbcoop,

My best guess is that you missed the registration of the configsection, it should look something like this:

  <configSections>
    .... 
    <!-- Note 1 of 5: Register the custom web.config section -->
    <section name="WebConfigRoleProvider" type="WebConfigRoleProvider.Core.ConfigurationSection"/>
  </configSections>
 

If you did that as well, I would like to take a look at the whole config file. You can post it here, or drop me an email, jakob.gade@mail.dk. :)

 

Apr 17, 2010 at 11:14 AM

I think the problem was that I left the old sql membership providers in .. trying again now ...

Apr 17, 2010 at 11:24 AM

Lots sections in teh configsections -- I had it in the wrong one!

 

Thanks